Jump to content
aberdeen-music

Silvertone amp in case service


Recommended Posts

I've just aquired a very nice example of the Silvertone amp in case 1448,

Guitar is great, intonation surprisingly good!

The amp however, has no output, all 3 valves light up fine, but there is no sound at all, no hum or anything!

does anyone have an idea of what might be wrong, or somewhere/someone that could maybe fix it

Cheers

Link to comment
Share on other sites

Nice buy!

The only amp advice I can ever give is to go see Dennis Marshall.

This sounds similar to the condition my Twin was in when I obtained it. The problem was a busted transformer. Dr Dennis fixed that, re-valved the amp (pre-bought tubes) and did some other soldering work/service for 95 quid.

Link to comment
Share on other sites

Nice buy!

The only amp advice I can ever give is to go see Dennis Marshall.

This sounds similar to the condition my Twin was in when I obtained it. The problem was a busted transformer. Dr Dennis fixed that, re-valved the amp (pre-bought tubes) and did some other soldering work/service for 95 quid.

He replaced a transformer, plus all the other stuff, for £95? That's crazy good. Output transformers are well expensive.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...