Jump to content
aberdeen-music

DAW help? Crackly recording


meiklejohn
 Share

Recommended Posts

Hey guys, I'm using a tascam us-144mkii and reaper, I've got everything working fine other than a very slight but very annoying crackle whilst strumming the guitar. I've heard about this being latency so I have tried all 5 of the tascam latency options but had no difference between them? What else could this be? Or am I using it wrong?

Please help...

Frustration is kicking in which means I'm close to giving up haha

Scott

Link to comment
Share on other sites

You should be able to tweak the latency and frequency settings in Reaper as well, rather than on the Tascam itself. Not in front of my laptop just now so can't check where they are but should be straight forward. Might also be worth trying the asio4all drivers which can offer improved performance:

http://www.asio4all.com/

Thanks, I keep hearing this asio4all thing ill definitely check it out. My laptop has 4gb of ram so I can't see why it would be impossible to get a clean sound. I'm 100% new to this DAW stuff so I probably wouldn't know what to do even if I did find the latency thing on reaper. If you could have a look at yours and let me know roughly what to do, it would be greatly appreciated!

Link to comment
Share on other sites

I didn't bother reading this as I don't use Reaper but ultimately, when it comes to learning your DAW all you have to do is type your exact query into Google.  Someone else has definitely had the same problem as you.  Once you get used to the menus it will seem less daunting.  

 

http://wiki.cockos.com/wiki/index.php/How_to_Compensate_for_Interface_Latency

 

I typed in "adjusting latency in reaper" and this was the first hit.

 

I wouldn't pin my hopes on Aberdeen Music solving your Reaper problems quickly!

Link to comment
Share on other sites

Guest Tam o' Shantie

K the replies so far don't make much sense.

 

this sounds nothing like a latency issue but a buffer size issue...your computer processor is not able to play/record the audio you're working with in time resulting in stutters/crackles.

 

you need to increase the buffer size preferably on your DAW, meaning the software spends more time 'loading up' the audio in advance of it being played.

 

However, the downside is that latency will then occur - this is because there is now a delay while your computer spools up the audio, as opposed to the recording side which is (hopefully) live and in time. 

 

http://voices.yahoo.com/how-optimize-daw-buffer-latency-avoid-audio-8756363.html

 

it's usually a balancing act, you basically want your buffer size to be as small as possible to ensure that it isn't causing a delay, but large enough that the computer can process the audio/effects without stuttering.

  • Upvote 1
Link to comment
Share on other sites

Guest Tam o' Shantie

and yes, reaper may have some good latency adjusting feature

 

ableton does, once again its trial and error

 

maybe the OP could post an example of the audio affected. might even be clipping? lol

Link to comment
Share on other sites

what planet are folk on where they think that latency causes crackles?

 

I had crackling through my Line6 UX2 running into a Mac Mini (2012) and Logic Pro, turned out there were new drivers to cope with an issue (crackling) raised by running the UX2 into a USB 3.0 input. So it's not always as clear cut as you're making it out.

 

There's a lot of trial and error i guess. People are genuinely offering up ideas to help the guy and I really hope it is what you say it is otherwise your bravado and arrogance will just end up making you look like a dick.

Link to comment
Share on other sites

Guest Tam o' Shantie

I had crackling through my Line6 UX2 running into a Mac Mini (2012) and Logic Pro, turned out there were new drivers to cope with an issue (crackling) raised by running the UX2 into a USB 3.0 input. So it's not always as clear cut as you're making it out.

 

There's a lot of trial and error i guess. People are genuinely offering up ideas to help the guy and I really hope it is what you say it is otherwise your bravado and arrogance will just end up making you look like a dick.

 

yes your suggestion was good also, my so called bravado and dickishness was more towards the several people talking about something absolutely unrelated, i mean 'latent' is a dictionary defined word with context in this discussion.

 

crackling = possibly related to small buffer size

latency = delay/poor sync in multitracks due to increasing buffer size

 

it is like someone saying "help, my trousers are too tight, how do I solve this problem" and instead of people saying "you need to wear trousers with a bigger waist" they're saying "sounds like your trousers are too big mate, and that's why they're falling down to your ankles"

Edited by Tam o' Shantie
  • Upvote 1
Link to comment
Share on other sites

I have the exact same interface and had the exact same problem in the beginning. Sadly it was that long ago I cant remember what I did to fix it. 

Here are a run down of my settings in Sonar, the DAW I use.

Sampling rate: 44100
Buffers in Playback Queue: 2
Buffer Size: 5.8ms/256 samples
(Effective latency @ 44hz:5.8ms)

ASIO Driver version: 2.03
Drive Mode: ASIO
Dithering: Triangular
 

I have full chase lock, share drivers with other programs, use multiprocessing engine and use MMCSS all ticked. 

Use ASIO reported latency: 512

Everything else 0 or unchecked.

Oh look I can C&P the TASCAM config file, embarrassing.

[Aud]DataDir=C:\Cakewalk Projects\Audio DataPictureDir=C:\Cakewalk Projects\Picture CachePicCacheMB=500PicCacheZoom=128PicCacheLevels=2EnablePicCacheThreads=1ComputePicturesWhilePlaying=1CopyOnImport=1ReadCache=1WriteCache=0EnableCacheWriteThru=1VolMethod=1PanMethod=1DiskBufSize=256DiskRecBufSize=256ExtraDiskBuffers=2DitherAlgorithm=5ZeroFillMethod=2RecordPreAllocSeconds=0ZeroFillDB=300FlushWriteBeforeRead=0FlushMultiple=1DefaultEqPosition=0DefaultAudSnapOfflineStretchMethod=3DefaultAudSnapOnlineStretchMethod=1RadiusStretchingPitchCoherence=50RadiusStretchingPhaseCoherence=50RealtimePreroll=0SuspendPluginsOnBounce=1[Wave]DefaultSampleRate=44100DriverID=0WaveInID=0OpenInputFirst=0SmpteMode=1TimingOffsetMsec=0.000000TimingOffsetBuffers=0LatencyMsec=4BounceBufSizeMsec=0FlushOnStop=1ThreadSchedulingModel=1EnableMixThreads=1MixThreadCount=0EnableSetThreadIdealProcessor=1CSUseSpin=1AllowOfflineRenderMixThreads=1UseMMCSS=1MMCSSThreadPriority=2MMCSSTaskKey=Pro AudioFreeMemOnUnload=1AlwaysOpenAllDevices=0MinimizeDriverStateChanges=1RemoveDCOffset=0EnableAsioBufferSwitchTimeInfo=1EnableDeviceOutputLatencyCompensation=1UseHardwareSamplePosition=1BitsPerSample=24FileBitDepth=16RenderBitDepth=32ImportBitDepth=0ExtraPluginBufs=0MixDezipperUsec=50GapDezipperUsec=500WaveInBuffers=8WaveOutBuffersMME=4WaveOutBuffersKS=2MeterFrameSizeMS=40SyncMaxDriftMsec=2SyncDivisor=8ProfiledMME=0ProfiledKS=1ProfiledWASAPI=0UseWDMDmaForWASAPI=1LinkSendPan=0LinkPFSendMute=0StopOnEmptyPlayQueue=0KsUseInputEvent=0WaveOutExtraBuffers=1AutomationDecimationMsec=50EnableSSEMixing=1ThumbnailCacheSize=100ManageASIOThreadPriority=1EnableLiveADCRecalc=1UseAlias=0DropoutMsec=250StartFadeMsec=0StopFadeMsec=0PanLaw=0DisableIMDuringPlay=0ShowMultiChannelInputs=1ShowMultiChannelOutputs=1PanLawCompatMode=0[TASCAM US-144 MKII (2 in, 2 out)]MigratedDMA=1Name=TASCAM US-144 MKII 1/2InputLatencyOffset=0UseAsioReportedLatency=1WidePacking=0Interleave=2Use24BitExtensible=0UseExtensibleForMultiChannelIO=1WDM.DMA.11025=11 11 11 11WDM.DMA.22050=22 22 22 22WDM.DMA.44100=256 1024 256 1024WDM.DMA.48000=256 1024 256 1024WDM.DMA.88200=256 1024 256 1024WDM.DMA.96000=256 1024 256 1024WDM.DMA.176400=176 176 176 176WDM.DMA.192000=192 192 192 192WDM.DriverMap.UseWaveOut1=1WDM.DriverMap.UseWaveOut2=1WDM.DriverMap.UseWaveIn1=1WDM.DriverMap.UseWaveIn2=1[IDT High Definition Audio CODEC (2 in, 2 out)]MigratedDMA=1Name=MicIn2 [WaveRT]InputLatencyOffset=0UseAsioReportedLatency=1WidePacking=4Interleave=2Use24BitExtensible=1UseExtensibleForMultiChannelIO=1WDM.DMA.11025=11 11 11 11WDM.DMA.22050=22 22 22 22WDM.DMA.44100=44 44 44 44WDM.DMA.48000=48 48 48 48WDM.DMA.88200=88 88 88 88WDM.DMA.96000=96 96 96 96WDM.DMA.176400=176 176 176 176WDM.DMA.192000=192 192 192 192WDM.DriverMap.UseWaveOut1=1WDM.DriverMap.UseWaveOut2=1WDM.DriverMap.UseWaveIn1=1WDM.DriverMap.UseWaveIn2=1[SampleRates]Count=80=110251=220502=441003=480004=882005=960006=1764007=192000[US-122 MKII / US-144 MKII (2 in, 2 out)]InputLatencyOffset=0UseAsioReportedLatency=1MME.DriverMap.UseWaveOut1=1MME.DriverMap.UseWaveOut2=1MME.DriverMap.UseWaveIn1=1MME.DriverMap.UseWaveIn2=1[US-122 MKII / US-144 MKII (1 in, 1 out)]InputLatencyOffset=0UseAsioReportedLatency=1MME.DriverMap.UseWaveOut1=1MME.DriverMap.UseWaveIn1=1[AliasInput]US-122 MKII / US-144 MKII  in L=US-122 MKII / US-144 MKII  in LUS-122 MKII / US-144 MKII US-144 MKII analog in L=US-122 MKII / US-144 MKII US-144 MKII analog in LUS-122 MKII / US-144 MKII US-144 MKII digital in L=US-122 MKII / US-144 MKII US-144 MKII digital in L[AliasOutput]US-122 MKII / US-144 MKII  out L=US-122 MKII / US-144 MKII  out LUS-122 MKII / US-144 MKII US-144 MKII analog out L=US-122 MKII / US-144 MKII US-144 MKII analog out LUS-122 MKII / US-144 MKII US-144 MKII digital out L=US-122 MKII / US-144 MKII US-144 MKII digital out L

You can load that config I guess. I really wish I knew how to do that spoiler thing I see going about but oh well.

You'll get it working eventually, apart from the pop noise that appears in the recorded audio whenever the level led goes out its a nae bad unit.

 

Edited by Preid
Link to comment
Share on other sites

Guest Tam o' Shantie

mental amount of config here...must be terrifying to anyone not familiar with DAWs. 

 

personally I use ableton, menu has buffer size & latency compensation.

 

1. you make the buffer as small as possible before audio drops out

 

2. you use the latency compensation if the end result is a noticable amount of delay/sync issues between what you're playing and what ends up being recorded

 

these are the 2 basic principles of buffer size/latency, there shouldnt me much more to consider here...

Link to comment
Share on other sites

I am happy to try and help you on this, but the theory behind this is all over the internet so you're going to have to familiarise yourself at some point.

I thought I had explained it earlier quite well but I'll try and summarise it so that it makes sense as I know this stuff can be confusing when you're starting out.

The buffer is 'looking ahead' at the audio before you hear it, right? The idea is your computer is processing the audio a split second before it's playing it, so that you aren't hearing the stuttering/pops/crackles etc that you would hear if it was processing it and playing it at the same time.

The larger the buffer size, the more of the audio tracks it is processing silently in advance, meaning the less likely you are to hear pops/dropouts. Think of it like 'anti shock' on those old portable CD players. The player would look ahead so that if you knocked it and the CD skipped, it would just carry on playing seamlessly.

This all sounds great, but because you're asking it to process the audio before it plays back, there's a delay in doing so. In fact the delay is proportional to the buffer size. If you have the maximum size of buffer it's going to result in the smoothest playback but it's loading so much of the audio ahead of playing it that the two are now out of sync. This is fine if you're just listening, but if you're recording say an overdub along to your prerecorded tracks, the recording isnt suffering the delay that you have created with the playback and hence both parts may end up out of sync. Most DAWs can either auto-adjust this or have you set an automatic delay in the recording part to compensate and adjust everything into sync.

So in an ideal world you want the shortest buffer you can manage. this means setting it to the lowest setting (which will definitely pop/stutter) and gradually increasing it until your computer can handle the audio.

Does this make sense? If so you can hopefully look at the options and see where Reaper might be making your setup struggle, ie optimisation for low latency is going to = a small buffer which is going to = stutters. i would untick this, look at your asio settings and find a slider for buffer size, gradually increasing it until the audio plays smoothly. Unfortunately, or fortunately for me I don't have Reaper so I can't really go through the menus and figure it out for you. As it's been pointed out various times in this thread though, you should really be asking this type of software specific advice on the Reaper forum/s as folk there will know the environment inside and out.

Cheers mate, once I get home at 4 ill have a right good browse and sort it out. Will report back with my progress

Link to comment
Share on other sites

Here's a wee update, I downloaded ASIO4ALL to see if that made a difference, certainly easier to understand that's for sure! so finally got my mic set up and I tried that and there's not a crackle to be heard! so i plugged back in the 6 string and played, sounded okay to me, so it's only with my guitar and amplitube running...I think.

My sister is a bit of a whizz with computers and she was messing around and thinks she can fix it (thinks something's interfering in the background)

I'm gonna spend the weekend trying a good few things and see if I can get the swing of it.

Thanks for all your advice and help!

Much appreciated.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...