Jump to content
aberdeen-music

PlusNet Users?


mcsheepie
 Share

Recommended Posts

Guest Bailz
I know some people here use PlusNet (from the ISP thread) and i was wondering if any of you have had speed problems lately? I normally get 1600kbps and above and today i'm averaging 700 which is really annoying.

Is it just me?

Speeds have been up and down recently for me too. I'm not sure if this is with the change over to max dsl but it seems to be levelling out now :)

Link to comment
Share on other sites

I know some people here use PlusNet (from the ISP thread) and i was wondering if any of you have had speed problems lately? I normally get 1600kbps and above and today i'm averaging 700 which is really annoying.

Is it just me?

I haven't had any problems, but PlusNet as a whole is going to hell. What I'd do is try the BT Speedtest (can't remeber the details, but you'll find them on the PlusNet forums) three times, about an hour apart, and if you're receiving anything below 1000kbps, then complain.

Oh, and if your exchange is Aberdeen Denburn, get away from PlusNet before you get transferred onto Tiscali LLU :\

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...