Jump to content
aberdeen-music
Sign in to follow this  
Chi 666

peavey head

Recommended Posts

my peavey supreme head is fucked!

help me fix it.

everything works fine apart for the main input. i dont even hear a pop or click when i plug in my guitar! the wirings fine, and it all looks fine.

what could be the problem??(

Share this post


Link to post
Share on other sites
Guest lime ruined my life

first, eliminated the guitar/leads as the source of the problem.

Share this post


Link to post
Share on other sites
Guest MKII

How do you know everything works fine if you cant hear anything?

If it's not your guitar or lead(s), I supect this has maybe gone wrong.

outputtrans.gif

Share this post


Link to post
Share on other sites
dose anyone know anybody that fixes amps in aberdeen?

Look inside your amp, Does it have small glass fuses in there? These could be blown.

Can often be a cause of no sound from an amp that still powers up

Share this post


Link to post
Share on other sites

i havent came across anyoen that fixes amps (without sending them away)_ but you could try a sparky

alternatively, the guy at sound control in dundee is fucking excellent, cheap and isnt a scally

if he cant fix it he dont charge you etc

thoroughly reccomended.

Share this post


Link to post
Share on other sites

yeah I will go with stuarty on this one.... if you aren't confident enough to have a look / fix yourself then don't attempt it... best bet is soundcontrol - they are decent blokes down there!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×