Jump to content
aberdeen-music
Sign in to follow this  
marsh_mallowpies

Problem with Roland G-33 - any ideas?

Recommended Posts

Hi,

Desparate for some help.

I have bought a GR-33 synth with a GK-2A pickup, plugged it all in, followed the instructions and now having a major problem in that, well its not doing much.

I can tune my guitar perfectly and I can adjust the sensitivity, but I can't use any effects.

When the GK 2A is switched to guitar or mix I can play the guitar as normal through the amp. but have no effects coming through, when I switch the GK 2A to 'synth' I get nothing, not a sound out of my amp, just seems to cut off. Any ideas? have I got a dodgy one?

I am using an Ibanez semi acoustic Artcore series.

I am really frustrated, I have tried all the connections, restored factory setting, the lot. I have read the manual over and over but nothing has worked.

HELP!!

Thanks very much

Share this post


Link to post
Share on other sites

Take your guitar or synth unit to a music store and try each item individually. If the pickup works with the stores synth unit, replace the unit. If the pickup doesn't work with the synth, time to recheck your wiring. Try just plugging in the synth part without the guitar pickups, see if you can do anything with that. Could be any number of things, back pickup, bad wires, loose connection, etc.

Share this post


Link to post
Share on other sites

hmmm youve probably checked this but is the volume on the back of the unit turned up. ive made this mistake a few times with my GR-20 drove me crazy until i found out it was a tiny mistake like that.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×